cforms II User Forum

Registration is currently disabled.
Guest

FAQs

Login form protected by Login LockDown.


Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

    

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
XAMPP: cforms 5.5.1&5.52 crash apache
October 28, 2007
1:51 pm
ctree
Guest

The last two versions of cforms, 5.51 & 5.52, crash my local wordpress install but seemingly not the one on the live server. Strange stuff. When I access the page with the contact form (I only have one static page with the form), apache goes into deep think and crashes; the error log shows this (I'm showing two crash cycles):

 [Sun Oct 28 13:40:07 2007] [notice] Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.4 configured -- resuming normal operations
[Sun Oct 28 13:40:07 2007] [notice] Server built: Sep 21 2007 00:29:38
[Sun Oct 28 13:40:07 2007] [notice] Parent: Created child process 5196
[Sun Oct 28 13:40:10 2007] [notice] Child 5196: Child process is running
[Sun Oct 28 13:40:10 2007] [notice] Child 5196: Acquired the start mutex.
[Sun Oct 28 13:40:10 2007] [notice] Child 5196: Starting 250 worker threads.
[Sun Oct 28 13:40:10 2007] [notice] Child 5196: Starting thread to listen on port 443.
[Sun Oct 28 13:40:10 2007] [notice] Child 5196: Starting thread to listen on port 80.
[Sun Oct 28 13:40:43 2007] [notice] Parent: child process exited with status 3221225477 -- Restarting.
[Sun Oct 28 13:40:45 2007] [notice] Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.4 configured -- resuming normal operations
[Sun Oct 28 13:40:45 2007] [notice] Server built: Sep 21 2007 00:29:38
[Sun Oct 28 13:40:45 2007] [notice] Parent: Created child process 5360
[Sun Oct 28 13:40:48 2007] [notice] Child 5360: Child process is running
[Sun Oct 28 13:40:48 2007] [notice] Child 5360: Acquired the start mutex.
[Sun Oct 28 13:40:48 2007] [notice] Child 5360: Starting 250 worker threads.
[Sun Oct 28 13:40:48 2007] [notice] Child 5360: Starting thread to listen on port 443.
[Sun Oct 28 13:40:48 2007] [notice] Child 5360: Starting thread to listen on port 80.
[Sun Oct 28 13:40:56 2007] [notice] Parent: child process exited with status 3221225477 -- Restarting.

 

 Wordpress 2.3.1, cforms 5.52, Apache 2.2.6, php 5.2.4. Let me know if you need any other details.

October 28, 2007
1:57 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

I'm not sure how I can help here. I can't see how cforms code per se can break apache…all cforms does is replacing it's tag (in a post) with the HTML code.

Perhaps remove the plugin (delete all cforms data first!) and re-install.

October 28, 2007
3:00 pm
ctree
Guest

Sorry, Oliver! My fault – I had misconfigured my local apache install; everything is fine after I disable the cache_module / mod_cache.so in httpd.conf

October 28, 2007
4:09 pm
ctree
Guest

hmm, I still have the problem .. reverting to default httpd.conf doesn't help. It could be the latest version of XAMPP that's causing the problem – it has apache 2.2.6, mysql 5.0.45 and php 5.2.4. I believe the problem started to occur just after I upgraded Xampp. It only happens when I call the form (I use comments to call it), no form, no crash. I've tried removing the stats tables using the button on the settings page, then I removed cforms completely, deactivated the plugin and started over, without success. I also tried un-checking the gzip compression checkbox in Options > Reading, no joy.

October 29, 2007
7:23 am
ctree
Guest

[FIXED] Ok, it really is the Xampp installation that caused it after all – fixed it by downgrading to an earler version of Xampp. I will try to find out more and post again if i do.

October 29, 2007
11:20 pm
ctree
Guest

Here's a link to a xampp forum thread – the skinny: might be worth checking compatibility of cforms II with the versions of php (5.2.4) and apache (2.2.6) that xampp 1.6.4 bundles.

October 30, 2007
12:02 am
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

Thanks for the heads-up ctree!

Forum Timezone: Europe/Berlin

Most Users Ever Online: 959

Currently Online:
18 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

tracedef: 43

mores: 21

Gyrus: 20

frozenwaste: 18

asuffredini: 15

photoworks: 14

Member Stats:

Guest Posters: 3731

Members: 1463

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 5332

Posts: 18695

Newest Members: juredujmovic, dreamkeeper, rajattyagi, wrokaa, lukass

Moderators: Paul (421), cnymike (8), sonika (95)

Administrators: Oliver (6400), Nicky (3)