cforms II User Forum

Registration is currently disabled.
Guest

FAQs

Login form protected by Login LockDown.


Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

    

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
Wrong fields display in email
August 21, 2007
2:01 am
Marci
Guest

I am using Cforms on several places, and they are all wonderful -- except one. One of my forms works fine when I test it, but I get weird results when guests use it. The biggest problem is where they are supposed to indicate their "location". It's a single line of text, and it's required. But for some reason, in the message I get from the form, the location is usually replaced with a different field.

This form goes to an email list, where everyone should see the subject line as 

{Your Name} from {Your Location} is looking for a Christian Care Provider

 but Your Location is being replaced with either absolutely nothing (and it's a required field) or the contents of the long, detailed Additional Info field.

Whichever result I get, the same thing happens in the message body, so it SEEMS as if the person is answering the form wrong, but I just don't think everyone is so stupid to misunderstand the form. You can see the form at http://www.christianbirth.org/accp/find-a-christian-midwife/

If you would like access to admin, I'd be happy to provide it. I am just at a loss -- I have tried and tested many alternative configurations, but this continues to happen and I have no idea what could be causing the problem. Any suggestions would be appreciated. 

August 21, 2007
7:18 am
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

From a first glance, I think I know what the issue is. For some reason a little bug snuck in with grouped check boxes. You can try two (maybe 3) alternatives:

  1. position the grouped check boxes as the last field in "Your  Request"
  2. or set the form to non ajax mode (disabling the Ajax feature)
  3. there is a third, but in your case probably not be a legit alternative and that is, replacing the grouped check box with a Multi-Select-Field

See if this helps, if not we'll try something else.

 

August 21, 2007
7:44 am
Marci
Guest

Thanks so much, Oliver. I have made change #1 as a starting point, and I'll let you know how that goes after a few trials with real guests filling in the form. It's not my favorite option from an aesthetics/logic standpoint (order of fields in the form itself) but it's a good place to begin. Thanks for the quick reply!

Marci :) 

October 15, 2007
2:56 am
Per Wilhelmsen
Guest

Hi, and thanks for a great form-addon!

I have tried solution 2, and it does not fix the issue.
As it is I unfortunately need the checkboxes in the location it is, as it's part of a context, and then used with an import-tool (the mail, that is).
Multi-select boxes just makes it hard for end users.
Any suggestions are welcome, as long as we can fix this little bug :)

Form can be viewed here:
http://www.infinite-innovation.net/alliance-application/

CForms 5.5 // Wordpress 2.3 // Firefox 2.0.0.6

October 15, 2007
7:47 am
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

The grouped check boxes feature should have been fixed since 5.4.

October 15, 2007
10:34 am
Alan Carter
Guest

I seem to be having the same checkbox group problem. I'm running 5.4 (the 5.5 download doesn't seem to be there yet). The URL is:

http://the-programmers-stone.com/embedded-figures-test/

When none of the "New Activities" boxes are checked, the value from the first of the radio buttons grouped below is used, and then values are mismatched. Also, data further down the form can be lost, so sorting it out with a script isn't an option. The mismatched data is also in the database table, so it isn't in the email generation.

The workaround isn't applicable because there is more than one checkbox group :-( Any suggestions gratefully received!

October 15, 2007
1:15 pm
Alan Carter
Guest

The checkbox group problem is completely sorted in 5.5, with a dash reported where there are no selections in the group.

5.5 is there, I was confused because History.txt is still at 5.4, but the functionality is there.

Many thanks!

October 15, 2007
3:11 pm
Per Wilhelmsen
Guest

Removed the old version again, and installed fresh – and voila. working.
Thanks  Oliver, this plugin will remain one of my favourites for quite some time!

Forum Timezone: Europe/Berlin

Most Users Ever Online: 959

Currently Online:
18 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

tracedef: 43

mores: 21

Gyrus: 20

frozenwaste: 18

asuffredini: 15

photoworks: 14

Member Stats:

Guest Posters: 3739

Members: 1463

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 5339

Posts: 18706

Newest Members: juredujmovic, dreamkeeper, rajattyagi, wrokaa, lukass

Moderators: Paul (421), cnymike (8), sonika (95)

Administrators: Oliver (6400), Nicky (3)