cforms II User Forum

Registration is currently disabled.
Guest

FAQs

Login form protected by Login LockDown.


Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

    

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
Upload direcotr does not exist
June 11, 2007
8:02 pm
Thomas
Guest

Hello,

 I m trying to use a form with the file upload feature, however the default setting are telling me that the directory does not exist.  what am i doing wrong?? should i change the deafult path to another path?  i checked the directories and they do exist…..

Please help

Regards,
Thomas

June 11, 2007
10:34 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

You might want to check the full path of the directory, just to make sure there is no typo etc. Also, double check permissions.

What happens if you use the default path (cforms sets it to …/attachments ) when adding a new form, does it also complain then?

June 11, 2007
10:41 pm
Thomas
Guest

thanks for your prompt reply.

 

the default path in cforms is set to D:hshomealfavillvirtualloscabos.com/wp-content/plugins/contactforms/attachments and it still shows me that the directory does not exist.  However i know it does exist. 

 my site name is http://www.virtualloscabos.com

What can i do?

thank you for your help in advance,
Thomas.

June 11, 2007
10:57 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

D:hshomealfavillvirtualloscabos.com/wp-content/plugins/contactforms

 doesn't look right to me. if indeed the first directory is called 'hshomealfavillvirtualloscabos.com' then I'd say there is at least a slash missing before it: 

D:/hshomealfavillvirtualloscabos.com/wp-content/plugins/contactforms

Also, are you sure you want to safe all attachemnts into your main cforms directory? There should be an "attachments" dir in "contactforms".

June 11, 2007
11:10 pm
Thomas
Guest

hi ,

I trully appreciate the fact that you're trying to help me with this.  It is so frustrating to me that i can't figure this out.  i tried what you mentioned and its still not working. 

I trust you enough to give you this info because its really important to me that i have it fixed.  quesiton though, if my website name is http://www.virtualloscabos.com then wouldn't the upload directory start with http://www.virtualloscabos.com/wp-content/plugins/…..ttachments ?

I tried all variations and still no luck.

 

June 11, 2007
11:33 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

I can't say how your web hoster organizes the file system, but when you add a new form, cforms tries to guess the right directory by looking at the ABSPATH variable, so it should set the default directory properly.

Add a new form and see what the default path says. 

June 11, 2007
11:38 pm
Thomas
Guest

Hi Oliver,

 When I add a new form here is what the default path says:

D:hshomealfavillvirtualloscabos.com/wp-content/plugins/contactforms/attachments

i can provide you with my admin / pass if that would more helpfull.

thank you ,

Thomas

 

 

 

June 11, 2007
11:53 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

It looks like the web server is a Windows server, so maybe there are some issues with how PHP accesses and checks for files/directories.

Anyway, have actually tried to submit an attachment? Is it in the email and on the server? 

June 11, 2007
11:58 pm
Thomas
Guest

Hi,

you can actually try to submitt the attachement yourself , its under http://www.virtualloscabos.com website under "submit attachement" page.  when you try to submit the form it takes you to the Page not found.

 tha't the message i get.

June 12, 2007
12:55 am
Thomas
Guest

i contacted the my host provider and they told me that they path i shold be using is D:\\home\\alfavill\\virtualloscabos.com\\ .  i have made those changes and i don't get the error "directory does not exist"  howerver when i submit the form again using upload feature i still get "page not found"

 what should i do?

Thanks,
Tom

Forum Timezone: Europe/Berlin

Most Users Ever Online: 959

Currently Online:
42 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

tracedef: 43

mores: 21

Gyrus: 20

frozenwaste: 18

asuffredini: 15

photoworks: 14

Member Stats:

Guest Posters: 3732

Members: 1463

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 5333

Posts: 18693

Newest Members: juredujmovic, dreamkeeper, rajattyagi, wrokaa, lukass

Moderators: Paul (421), cnymike (8), sonika (95)

Administrators: Oliver (6400), Nicky (3)