cforms II User Forum

Registration is currently disabled.
Guest

FAQs

Login form protected by Login LockDown.


Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

    

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
Tracking Data Not Showing, Even Without Other Plugins
March 5, 2009
2:59 am
Guest

I've searched extensively in the FAQs and forums but am still getting no Tracking display even though there's data in the tables and no other plugins besides cforms are enabled. I just see the ever spinning "processing, please wait…"

Using WP 2.7.1 and cformsII 10.3. Problem occurs on major Mac/PC browsers: IE, Firefox, Chrome, Safari.

What I've tried:

1) I turned off all plugins except cforms and emptied browser cache then reloaded the tracking page without success (there was data in the database tables to be shown). Plugins used:

- All in One SEO Pack

- cforms

- Events Calendar

- Exclude Pages from Navigation

- Google Analyticator

- Google XML Sitemaps

- Link Indication

- Page Menu Editor

2) With Tracking on, I keep sending new test forms and the database tables get larger and the entries show up on the Dashboard -> Recent cforms entries box.

3) Forms are included in tracking system and tracking turned on.

4) checked path in abspath.php

5) checked permissions on folders/files in plugins/cforms

6) Get access denied alert when trying to Download records from empty Tracking interface. Checked permissions on plugins/cforms/js/include/ and files therein as this path is used when access denied page results.

7) Tables are properly created. Tried to delete tables from cforms Global Settings -> Database Input Tracking and then recreated them from cforms. Again, they are created fine. 

8) Checked cforms-global-settings.php for matching database table names. All seems fine. Don't know what to check for exactly in this file.

9) In Firebug on Firefox 3.0.6, I get console error alert:

Access to restricted URI denied" code: "1012

Detailed Error:

(?)()(function())common.js…=20081210 (line 377)

(?)()()jquery.j…e3Q%3D%3D (line 1)

(?)()()jquery.j…e3Q%3D%3D (line 1)

(?)()([function(), function(), function(), 4 more...], function(), undefined)jquery.j…e3Q%3D%3D (line 1)

(?)()()jquery.j…e3Q%3D%3D (line 1)

[Break on this error] gf = new ActiveXObject('Gears.Factory');

I don't what what this means but I did check the permissions on both common.js and wp-gears.js files that this error references in wp-admin/js folder. They're like all of the others using 664 on files and the folders at 775. 

___________________

Update: 

The cforms adding button that's available when in Visual editing mode on a page pr post is also not working I just noticed. When clicked, the modal window appears but is empty. Firebug errors:

  • Permission denied to get property Window.tinymce
    [Break on this error] gf = new ActiveXObject('Gears.Factory');
  • tinyMCEPopup.editor is undefined
    [Break on this error] var themeBaseURL = tinyMCEPopup.editor.b…mes/' + tinyMCEPopup.getParam("theme"));
  • tinyMCEPopup.onInit is undefined
    [Break on this error] tinyMCEPopup.onInit.add( function(){win…mentById('nodename').focus();},500);} );
  • this.onInit is undefined
    [Break on this error] this.onInit.add(function() {
I notice that the [?] help button that pops up a modal window still works, but I don't know if they use related methods or not.
March 5, 2009
8:24 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

Thanks for making the effort to rule out things and describing the status quo.

I'm happy to take a quick look (which may be the fastest way to resolve this) – pls send temp login credentials via my contact form at the top.

March 5, 2009
9:50 pm
Guest

That's very kind and much appreciated. Thank you!

However, I ended up uninstalling *everything* and starting over from scratch, even deleting the cforms plugins folder itself and downloading a fresh one. Also, I didn't use the global backups.

Everything was recreated and all seems to be working.

Funny though that after starting fresh, I activated the new cforms plugin and only created a default form. Then I again tested that the cforms button in the TinyMCE Visual toolbar worked in a Page. It did not work! i just got a blank modal window like before.

I then deactivated all plugins except cforms again. Went back to the Page and tried the cforms button again. This time it worked and the normal form selection menu showed up in the modal window!

Of course, I thought it must be one plugin. So, to test, I activated all plugins again to see if it would stop working again, then went back to the Page, and tried it but this time with success when just seconds before it did not in the same environment! How confusing.

Anyhow, I then went ahead and added all of the forms necessary to the site and all seems to be working with all plugins activated. 

March 6, 2009
5:43 pm
Guest

CFORMS CORRUPTION ISSUE MAY BE A CLUE

I forgot that I had corrupted cforms at one point (though it was early on in a cloud of many other issues when developing a site and I don't know if the problem started after that).

Specifically, I had been building WP with a hosting account specific URL (before the domain name transfer finished). Once the domain name was ready, I exported the database via phpMyAdmin and used a text editor to replace all instances of the old hosting specific URL with the new domain name.

When I imported this modified .sql file back in to the database, everything worked fine except cforms which reported a corruption error.

Cforms was unable to fix it and so I had to choose the other option to reset it.

Since I had Global Backup from when I was using the hosting specific URL, I was able to import that to retrieve all of my forms and settings. However, it never occurred to me that the cforms Global Backup file would need to have the URLs fixed also.

It's interesting to note that everything seemed to work fine in cforms after importing this older URL Global Backup file. All of the forms came through intact and sent form data properly via email as normal. I also do not remember having problems with the Visual editor cforms button when adding forms to a Page or Post. That seemed to happen spontaneously at some later point. Sorry, this is all kinda vague.

I can't be sure if this was when the Tracking stopped or not, but it could be a clue to the problem if others experience the same.

March 17, 2009
5:52 pm
Allie
Guest

I ran into this exact same problem today—and I also built the site on a different server, then moved it, did a find-and-replace, etc.

After changing everything, including the abspath and the js, restarting, etc., I finally just deactivated and reuploaded a fresh install from here.

Works like a charm now—must be something weird about moving from one server to another.

Thanks—

March 31, 2009
8:51 pm
Guest

I had the same problem.

Turns out disabling Google Analytics plugin fixed this.

Nice plugin!

April 24, 2009
3:20 pm
pete
Guest

hi guys,

i had this error as well. tired disabling other plugins and whatnot, but the easiest thing was the solution. i simply deactivated and re-activated Cforms!

my issue, i think, was that i changed the URL of the blog after installing the plugin originally.. from http://domain.com to http://www.domain.com .

pete

June 21, 2009
4:27 am
Guest

Same issues here…. disabling and re-enbabling solved….

September 17, 2009
9:04 pm
Ross
Guest

This is what cause my installation of cforms to stop working properly in this way.

If you are using a plugin like All in one SEO, then you likely set "Canonical urls" on (Settings>All in one SEO) and changed your Wordpress and Blog URLs in Settings>General.

Simply changed the URLs in general settings back (took the www out or put it back depending on how you had it set), and it all works fine again.

This is why mine did exactly what you guys mention above…

Hope this helps.

September 18, 2009
6:31 am
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

Thanks for the hint!

Yes, cforms doesn't expect the WP URL to change "on the fly", so if any other plugin manipulates the URL in real-time, there might be a conflict.

February 10, 2010
4:07 pm
james
Guest

I have figured this out .. finally ..

if this page has xml error then it breaks the display

/wp-content/plugins/cforms/js/include/lib_database_overview.php

most likely cause is line break at the top of the xml

for me this was caused by extra line break in theme functions file.

hope this saves someone the 2 wasted hours of my life finding the cause of this error.

J.

January 20, 2011
6:21 am
Guerilla Design Serv
Guest

I had this same problem…deactivate and reactivate worked for me thanks.

February 29, 2012
1:47 pm
Vinyl
Guest

Does "deactivate and reactivate" erase the forms settings ?

 

I need to know because i have this issue (Tracking Data Not Showing) and i'm afraid to loose all my forms… Thank you.

 

/Sébastien

February 29, 2012
5:52 pm
Vinyl
Guest

I answer to my question oops

 

We can "deactivate and reactivate"  cforms without erase settings.

June 16, 2013
2:37 am
sanjay kumar
Guest

Check you if   your site is hosted at dedicated ip or shared.  If shared the ip address returned would have port info and the db write will fail field size failure 

http://sanjaykumar.azurewebsites.net/index.php/cat…..ss/cforms/

September 13, 2013
2:06 pm
Ash
Guest

Mine was fixed by deactivating NextGen Gallery.

Thanks

Ashsf-smile

October 4, 2013
6:14 pm
JMDezigns
Guest

The latest updates of NextGen Gallery are causing the tracking not to display the submissions.  Disabling NextGen Gallery solves the issue for me, but this is obviously not a long term solution.

February 3, 2014
7:09 pm
Stunami
Guest

I will confirm this
Wordpress 3.7.1
NextGen Gallery 2.0.4.0
Cforms II 14.6

NextGen Deactivated Tracking list works fine.
NextGen Activated Tracking gives a "connection error" message

However, the records are there one at a time and one CAN export data.

March 5, 2014
5:01 pm
Erich Oliveira
Guest

comment the lines 2 and 14 of the file wp-content/plugins/cforms/js/include/lib_database_overview.php 
//ob_start ();

//ob_end_clean ();

May 23, 2014
4:14 am
Bryan Cady
Guest

The above post worked by commenting out line 2 and (actually) line 114 not 14 to fix a tracking hiccup in the latest version of cforms. 

What is this exactly doing?  Is this possibly breaking something else?  From reading the PHP, it appears it was written for compatibility of an older version of WordPress??

Thanks

Bryan

Forum Timezone: Europe/Berlin

Most Users Ever Online: 959

Currently Online:
30 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

tracedef: 43

mores: 21

Gyrus: 20

frozenwaste: 18

asuffredini: 15

photoworks: 14

Member Stats:

Guest Posters: 3731

Members: 1463

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 5331

Posts: 18693

Newest Members: juredujmovic, dreamkeeper, rajattyagi, wrokaa, lukass

Moderators: Paul (421), cnymike (8), sonika (95)

Administrators: Oliver (6400), Nicky (3)