cforms II User Forum

Registration is currently disabled.
Guest

FAQs

Login form protected by Login LockDown.


Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

    

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
sajax_uri possibily?
January 24, 2008
7:41 am
Ridge
Guest

Please replace the ??? with your data!


[desc]:First I apologize for asking a question which I know is answered in the FAQ it just goes beyond my comprehension.  I do get the message:

"It seems that your ROOT directory for Wordpress is /X. If you encounter issues with Ajax (form submission & CAPTCHA reset) please check the file js/cforms.js in your cforms plugin folder and set the sajax_uri variable accordingly."

 I've looked at the sajax_uri and read the tips but I still do not know what it is asking for (paths, index, etc?)   It may not be the problem at all but when the "Submit" button is pressed nothing appears to happen.  

To note: This plugin is exactly what I was needing and I thank you for your services.

-Ridge
_

January 24, 2008
7:51 am
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

cforms already tries to identify if your blog has been setup using a prefix.

This is would a regular install: http://site.abc.com/

This would be one using a prefix: http://site.abc.com/UF2 in this case UF2 but it could be anything.

If Ajax doesn't work:

  1. clicking submit may not work : form stalls
  2. or CAPTCHA reset doesn't work

Then you need to tweak that sajax_uri variable as described and per the examples in cforms.js file:

To do that you need to replace the existing (default) line:

var sajax_uri = '/';

with a modified one,e.g.:

var sajax_uri = '/UF2/';

 

—-
PS: If you modifiy this CSS style in your current cforms theme (~line 136), then your select box will be in the right place:

in .cform select {…

set margin-left:0px;

January 24, 2008
9:15 am
Ridge
Guest

Oliver,  thank you for the rapid response.  Everything is working based on your information.  Much appreciated.

January 24, 2008
10:30 pm
Kai
Guest

Thank you! this also clarifies my insecurities in which situtations I have to fix this.

 

In my case, submitting the contact form works, but I only receive an empty message (with the "reply to" set to the user-submitted e-mail though, so I can get in touch with them, their messages are lost though.)

 

Kai 

January 24, 2008
10:42 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

Kai, have you double checked all admin settings: message text for TXT and HTML, inclusion of data, proper {variables} (if used) etc.

If you can't fix it, send me an email. 

January 28, 2008
10:05 pm
Sjoerd
Guest

Hi Oliver, hope you can help. I have the same problem as Ridge. I would really like to use Cforms, I've installed it on another blog without any problems, now i'm trying to get it to work on my own blog. But without any luck.

My Wordpress is installed in the folder http://www.site.com/wp so i changed the cforms.js file like this:

var sajax_uri = '/wp/';
// var sajax_uri = document.location.pathname;
// var sajax_uri = 'YOUR-ABSOLUTE-PATH-TO-THE-PAGE';

Do I need to change the other two lines as well? Because it still doesn't work, Cforms shows a warning message.

Hope you can help, thanks in advance,

Kind regards, Sjoerd

 

January 28, 2008
10:25 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

Nope, what you did looks good. If you run on IIS you might want to check the FAQs.

January 30, 2008
2:11 pm
Sjoerd
Guest

Hi Oliver, thanks for your quick reply. I'm not sure if i run on an IIS…Can you please telle me more and provide a link to the FAQ's? I couldn't find them.

Thanks again!

kind regards, Sjoerd 

January 30, 2008
6:33 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

Hi! The troubleshooting FAQ is among the first sticky posts in the Troubleshooting forum.

Forum Timezone: Europe/Berlin

Most Users Ever Online: 959

Currently Online:
28 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

tracedef: 43

mores: 21

Gyrus: 20

frozenwaste: 18

asuffredini: 15

photoworks: 14

Member Stats:

Guest Posters: 3762

Members: 1463

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 5359

Posts: 18741

Newest Members: juredujmovic, dreamkeeper, rajattyagi, wrokaa, lukass

Moderators: Paul (421), cnymike (8), sonika (95)

Administrators: Oliver (6400), Nicky (3)