cforms II User Forum

Registration is currently disabled.
Guest

FAQs

Login form protected by Login LockDown.


Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

    

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS Related Topics
Passing variables in Multi-page forms
Trying to pass variables from first page of multi-page form to final page "Auto Confirmation" and "Admin Email Message".
August 24, 2012
10:15 pm
Dr. T
Guest

I have setup a multi-page form with 4 pages. Everything seems to be working fine. I have turned OFF "Admin Email" and deactivated "Auto Confirmation" for the first 3 linked pages. I've turned ON and configured "Admin Email" and activated "Auto Confirmation" on the final page of the form.

Both the "Admin Email" and "Auto Confirmation" send correctly although the one field I am trying to include is {Name}. Sadly it just appears as {Name}. This is strange because the User Input with all of the collected info on all 4 pages appears correclty (including NAME).

What am I missing? How do I get the {Name} variable to appear correctly?

August 25, 2012
10:56 am
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

Pls check the Help page (or try the forum search) for how to reference multi-page form variables…

August 28, 2012
5:55 pm
Dr. T
Guest

I was able to find the answer in the HELP section. Here is some additional info:

Referencing form values in multi-page forms require specification of the actual form the field is on, eg. {cf_form6_Your Name} would reference the field labeled "Your Name" on form #6. For my situation it was the first form so I used {cf_form_Name}. Make sure you also select "Use custom input field NAMES & IDs".

April 9, 2014
9:33 pm
EPCrating.co.uk
Guest

I have cforms installed on my website, but the multi-form variables are not passing to the email, I have refrenced the help and $cformsdata to obtain variables…I have followed the instructions carefully everything is up and running apart from the variables (Received an email will variable list) tried the variables and still no luck. I have struggled for days trying to get this plugin working and looking nice, but this last problem stands in my way. (I'm no programmer just trial and error but im struggling somebody please help me) my form is located @ EPCrating.co.uk and runs throughout the website using the sidebar css widget.

Forum Timezone: Europe/Berlin

Most Users Ever Online: 959

Currently Online:
26 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

tracedef: 43

mores: 21

Gyrus: 20

frozenwaste: 18

asuffredini: 15

photoworks: 14

Member Stats:

Guest Posters: 3757

Members: 1463

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 5356

Posts: 18735

Newest Members: juredujmovic, dreamkeeper, rajattyagi, wrokaa, lukass

Moderators: Paul (421), cnymike (8), sonika (95)

Administrators: Oliver (6400), Nicky (3)