cforms II User Forum

Registration is currently disabled.
Guest

FAQs

Login form protected by Login LockDown.


Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

    

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
Page inclusion error
October 14, 2012
1:16 am
NetzBlogR
Guest

Hi,

I use a function to include the content of a page called \"Impressum\" inside my posts. You can see an example here: http://www.falk-wussow.de/frisch-geschluepft (click the speech bubble).

The code looks like this – and does it in 14.5:

«div»
«h4»Headline 1«/h4»
«p»1st line«br /»
2nd line«br /»
3rd line«p»

«h4»Headline 2«/h4»
«p»1st line«br /»
2nd line«br /»
3rd line«p»
«/div»

After updating to 14.6, the HTML tags P and BR have gone and so it looks like this:

«div»
«h4»Headline 1«/h4»
1st line 2nd line 3rd line
«h4»Headline 2«/h4»
1st line 2nd line 3rd line
«/div»

I downgraded to 14.5 and it worked again.

I think it has no serious impact on many blogs, becaus this scenario is very rare, but I just wanted to let you know. :-)

October 14, 2012
11:34 am
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

Yep, by design. :-)

I've been getting numerous requests about WP injecting its own P and BR tags all over the place, which imho it shouldn't do. To allow everyone to take full control over the form layout without WP messing it up, I disabled WP's wp_autop 'feature'.

It may cause some minor adjustments for some blogs, but ultimately it'll give you back the layout control, WP took from you.

PS: can you re-download v14.6 – I've made a last second change and updated the ZIP, this should help.

October 14, 2012
7:15 pm
NetzBlogR
Guest

Thank you. Now it works. :-)

October 16, 2012
6:11 pm
Twist
Guest

Hi there,

This may be related to the above points…

After updating to the latest cforms 14.6 – my contact and booking pages (the pages with forms on) lost their paragraph spacing, some text disappeared and all embedded images were not displayed. 

Although I have a short contact form in a footer widget on every page, only the contact and booking pages on my site were affected as they have the cforms shortcode directly on the page: http://www.interactivemagician.co.uk/hire-a-magician/ 

I had to revert back to 14.5 for everything to display as intended! 

I cannot remember when I installed the latest version, it probably was just before 14th October, are you saying that you have now changed 14.6 to remove this issue??

Is it worth me trying to install the update again?

Thanks in advance for your help!

October 21, 2012
7:10 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

I think so.

Forum Timezone: Europe/Berlin

Most Users Ever Online: 959

Currently Online:
24 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

tracedef: 43

mores: 21

Gyrus: 20

frozenwaste: 18

asuffredini: 15

photoworks: 14

Member Stats:

Guest Posters: 3731

Members: 1463

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 5332

Posts: 18695

Newest Members: juredujmovic, dreamkeeper, rajattyagi, wrokaa, lukass

Moderators: Paul (421), cnymike (8), sonika (95)

Administrators: Oliver (6400), Nicky (3)