cforms II User Forum

Registration is currently disabled.
Guest

FAQs

Login form protected by Login LockDown.


Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

    

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
one form hangs... but the rest work?
July 2, 2012
7:56 am
affa
Guest

All are ajax enabled.

Our main contact form hangs with the standard 'one moment please…' message, but we have several other contact forms on the site, all ajax enabled that work properly.

I'm up to date on CFORMS and Wordpress.   Any ideas?
Would deleting the form and recreating it have any effect?

July 2, 2012
9:59 am
affa
Guest

Okay, 3 hours later I have more information.

I tried duplicating one of the forms that worked, and replaced the single form that didn't.   It then worked. I then changed all the fields to match the original… and it stopped working.

So, I tried again. I duplicated the same working form, but this time, I changed one field at a time, saved, tested.

I have determined, and tested into the ground, that the form absolutely requires a 'file upload box' or it stops working and hangs.   If I delete it, the form hangs. If I add a new field, it won't work… unless that field is a file upload box.

And to add more mystery? I have another working form on our site that doesn't have a file upload box.

I am absolutely flummoxed.  I have no idea what is happening, only that it took me hours to figure out this oddity.

August 24, 2012
3:14 pm
Philppa
Guest

Hi Affa,  I am also having this issue.  I agree that forms work OK only if they have File Upload fields in them.  As a short term fix, I've added in File Upload fields to all those forms that were not working (ie they were hanging with the "One moment please…" message) – this seems to have fixed the problem though it isn't ideal!   Have you recently updgraded to a multiuser version of Wordpress – I have & I wondered if this may be part of the problem.  Maybe the plugin doesn't quite work as expected with a Wordpress network of blogs? 

Hi Oliver – do you have any ideas on this please? Also when cforms is on a multiuser version of Wordpress the Save command on the form in the top menu bar goes missing.

Here's the WP instructions I followed to install the multi user version: http://codex.wordpress.org/Create_A_Network

Thanks for your help…

Philippa

Forum Timezone: Europe/Berlin

Most Users Ever Online: 959

Currently Online:
23 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

tracedef: 43

mores: 21

Gyrus: 20

frozenwaste: 18

asuffredini: 15

photoworks: 14

Member Stats:

Guest Posters: 3763

Members: 1463

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 5359

Posts: 18742

Newest Members: juredujmovic, dreamkeeper, rajattyagi, wrokaa, lukass

Moderators: Paul (421), cnymike (8), sonika (95)

Administrators: Oliver (6400), Nicky (3)