cforms II User Forum

Registration is currently disabled.
Guest

FAQs

Login form protected by Login LockDown.


Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

    

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS Related Topics
Multi-Part forms stopped working after WP & Thesis upgrade
September 16, 2010
3:24 am
Guest

Anyone know where I should check first.  Its been working great for over a year (long enough that I totally forgot how everything works).  I upgraded to the latest Wordpress and Thesis, and also from 11.3 to 11.5 of cforms.  I then rolled back to the 11.3 and get the same problem so I am pretty sure the Wordpress or Thesis upgrade is the cause.  Basically everything works fine for a single page form, but all of my multipage forms upon submission just reload the same page.

 

If I remove the check for "Suppress admin email and DB tracking for *this* form" on the first form, I do get an email with the submission, but it still does not pull up the next form in the series.

September 16, 2010
7:10 pm
Guest

I reverted back to Thesis 1.6 , from 1.8, and it started working again.  I need to be able to keep current with Thesis so I'd like to get this figured out.  Anybody else experience this or have any ideas?

October 5, 2010
2:42 am
Guest

I can confirm this. Cforms 11.6.1 + Thesis 1.8 = Multipage broken. From searching the forum, others seem to be having problems with newer versions of Thesis, but unfortunately no solutions. Testing with other themes do work, however moving to another theme won't be an option for my client. Building the form with the plugin was supposed to be the 'easy' part of this project, but since it just doesn't seem to work, I'll have to come up with another solution :(

March 16, 2011
1:29 am
Guest

I tried again and it is still broken.  Are only 2 of us having this issue?  Can anyone please help?

March 16, 2011
10:44 pm
ash
Guest

I have installed this plugin (ver 11.7.3) with new installation of wordpress 3.1 with no other plugins installed, but it is not saving any data at all. Even after trying multiple time even the form name is not changing and not saving any other information.

 

Please help me, or if you can suggest any other plugin that creates multi part formsfrownfrown

June 1, 2011
7:11 pm
Bucko
Guest

I can confirm I'm also having this problem. I've only been using Thesis for a few months now, so have only used 1.8 (so I don't know if it would work on an older version) and cforms for only about a month now on several other sites with no problems up to now. I'm now trying to add a multi-part form but I just get redirected to the url of the page I'm on with "#usermessage2a" tagged onto the end, and all I see is the first form all over again (all fields cleared). This happens regardless of a successful submission or one with errors. Any help on this would be greatly greatly appreciated! (though I see this topic has been open and unanswered for several months now).

 

The only guess I have is that there is some sort of conflict with another plugin or feature of thesis…? But I don't know where to look. One other potential clue is that I tried to do a RegEx for validating dates. I tried several different ones from the library referenced in "Help!" and all gave me the same PHP error at the top of my page.

 

I hope this helps solve the problem!

 

Thanks in advance.

June 1, 2011
7:36 pm
Bucko
Guest

I would like to add something that I JUST found out and this could be very useful in potentially solving this. Just in the process of debugging I put a form that I knew worked (from my sidebar) into the content area, and it behaved differently, namely the success and failure messages didn't show up. I also tried to make it the first of a multi-part form, and had the same problem. At this point I forgot to remove the multi-part form function and put it back in my sidebar. When I inputted information to double check the form in the sidebar was all good, the success message came up as it should as well as the from that I had put as the next form! So this means that multi-part forms work in Thesis 1.8 and wordpress 3.1.2 (what I'm using) but only in the sidebar for some reason. If you want to see what's going on, the address is: http://www.thechinastep.com/apply-now (sorry for the unfinished state of the site! Still under construction)

 

Hope this helps. Would really love to get this fully functional as it's such an incredible and versatile plug-in. By far my favorite of the few I use!

September 4, 2011
12:39 am
Liz
Guest

Did you ever get this figured out?  My multipart form won't advance and instead just takes me back to the first form with a '#usermessage5b' tacked on to the end of the url, as described by someone else above.  Here's the URL, though you won't be able to test it because it requires log in and code verification.

http://www.boulderblueline.org/multipart-form-test/

 

Thanks.

September 11, 2013
7:00 am
John
Guest

I was having the same issue.  Dug into the code, tried almost everything.  When I switched themes the non-ajax error messages showed.  I finally figured it out.  Thesis 1.8 and WP 3.6.  I had to give the Meta Description on the page the cform was on a value.  Hope this helps someone.

Forum Timezone: Europe/Berlin

Most Users Ever Online: 959

Currently Online:
24 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

tracedef: 43

mores: 21

Gyrus: 20

frozenwaste: 18

asuffredini: 15

photoworks: 14

Member Stats:

Guest Posters: 3762

Members: 1463

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 5359

Posts: 18741

Newest Members: juredujmovic, dreamkeeper, rajattyagi, wrokaa, lukass

Moderators: Paul (421), cnymike (8), sonika (95)

Administrators: Oliver (6400), Nicky (3)