cforms II User Forum

Registration is currently disabled.
Guest

FAQs

Login form protected by Login LockDown.


Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

    

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
Javascript error with data picker
February 5, 2008
6:25 am
Paul Johnson
Guest

Please replace the ??? with your data!


[desc]:Hi there, thanks for such a great plugin. It's all working great for me except for the javascript date picker. I've activated it and placed a date of birth field at the bottom of my form, however clicking the date picker icon does nothing, and generates an IE error

Line 195 – Error – 'dp' is undefined.

Any help would be greatly appreciated._

February 5, 2008
7:16 am
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

That's an easy one. Please the check the FAQs for wp_head(); that'll fix your layout troubles, too.

February 5, 2008
7:32 am
Paul Johnson
Guest

Sesational support Oliver. Thank you very much..

February 5, 2008
7:42 am
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

You're welcome.

PS: Depending on which CSS Theme you choose, some 'proxy' elements may be necessary to complete the layout. E.g. with multiple fieldsets you need a closing element (not the "Fieldset end").

There is a brief explanation in the CSS Theme header on what to do.

And if you change this:  dark-rounded.css (~line 221)

p.cf-sb {
margin:0pt !important;
padding:0pt !important;

 That'll fix that empty space below your submit button.

February 5, 2008
11:33 am
Paul Johnson
Guest

Hi Oliver..

Thank you for all your support.. however, while placing the wp_head tag made the form functional and look great, it unfortunately introduced a new error..

 

I am now unable to submit the form! :) on pressing submit an error occurs:

Line 239: Invalid procedure call or argument.

If I remove wp_head from the header file and re-load the form, it obviously loses its stylesheet, but it submits correctly.  I've also found that if I turn off AJAX I can keep the wp_head in and it submits, but if I reactivate AJAX it fails.

Any thoughts you have would be greatly appreciated. At present I've left wp_head in the header and AJAX active so you can see what its doing.

Thanks.

February 5, 2008
12:09 pm
Paul Johnson
Guest

Nevermind!!

 

On inspecting further I assumed it was a javascript/AJAX issue. My solution to anyone else having this problem in the future was to put my full domain name in to the

 

var sajax_uri = line of wp-content/plugins/contactforms/js/cforms.js

 

once done it worked like a charm.

 

Thanks for all your help!

February 5, 2008
7:16 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

sajax_uri

 

That would have been my guess, too.

 

Forum Timezone: Europe/Berlin

Most Users Ever Online: 959

Currently Online:
25 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

tracedef: 43

mores: 21

Gyrus: 20

frozenwaste: 18

asuffredini: 15

photoworks: 14

Member Stats:

Guest Posters: 3757

Members: 1463

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 5355

Posts: 18732

Newest Members: juredujmovic, dreamkeeper, rajattyagi, wrokaa, lukass

Moderators: Paul (421), cnymike (8), sonika (95)

Administrators: Oliver (6400), Nicky (3)