cforms II User Forum

Registration is currently disabled.
Guest

FAQs

Login form protected by Login LockDown.


Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

    

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
Choose recipient with select box?
May 6, 2007
4:26 pm
Bob Yexley
Guest

I'm trying to create a form that provides the user with the ability to select the recipient of the message submitted from the form with a select list. I've created a select list that will allow them to choose the recipient, but, of course, the sent message doesn't go to the selected person, it goes to the address specified in the "Form Admin" section of the forms administration. Any ideas how I can dynamically set the recipient to the one chosen in the select box?

May 6, 2007
5:12 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

You need to do two things:

  1. add a "Multiple Recipients" field (essentially a multi-select box, but appears in the field-list as a separate item)
  2. according to the number of recipients, add the corresponding emails addresses in the correct order into the form admin email configuration. entries have to be seprarted by comma.

The Help! section shows an example.

 

May 6, 2007
11:17 pm
Bob Yexley
Guest

Thank you very much. That seems to have worked. It does lead me to another question though. On this custom form that I've created, I added a "subject" field, so that the writer could create their own subject for the message they send. However, the messages that get sent are still using the subject line specified in the form admin. Is there a way that I can force the message subject to be the one specified in the form?

I also seem to be noticing that, in the received messages, the field values seem to be off by one. As an example: The form that I'm referring to is at http://enjoycharis.com/?page_id=34. The form is titled "Contact Charis", and the resulting messages look like this:

A new submission (form: "Band contact form")
============================================

Submitted on: May 6, 2007 @ 4:52 pm
Via: /
By xxx.xxx.xxx.xxx (visitor IP)

————————Contact Charis———————

Contact:

Your E-mail:                    Yex
Subject:                        test@e-mail.com
Message:

Another form test

:                               Again…testing the contact form

( ======= end message ======= )

Do you happen to have any idea why the fields seem to be out of sync with the form? Thanks again very much for your help. 

May 7, 2007
4:15 am
Bob Yexley
Guest

Aw sheesh. Disregard that last followup question. I figured out what I was doing wrong…it was my fault. Thanks again.

May 7, 2007
8:27 am
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

Glad it works, can you share with the other users what solved the issue?

Thanks

 

Forum Timezone: Europe/Berlin

Most Users Ever Online: 959

Currently Online:
29 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

tracedef: 43

mores: 21

Gyrus: 20

frozenwaste: 18

asuffredini: 15

photoworks: 14

Member Stats:

Guest Posters: 3740

Members: 1463

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 5340

Posts: 18707

Newest Members: juredujmovic, dreamkeeper, rajattyagi, wrokaa, lukass

Moderators: Paul (421), cnymike (8), sonika (95)

Administrators: Oliver (6400), Nicky (3)