cforms II User Forum

Registration is currently disabled.
Guest

FAQs

Lost password?
Advanced Search:

— Forum Scope —



— Match —



— Forum Options —




Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS Related Topics
Cforms Tracking (Recent cforms entries » )
February 20, 2012
4:01 pm
Jo
Guest

The form works fine and submits fine, but the tracking piece (clicking on Recent cforms entries »)  just says one moment please and wont load the data, it will show up on the dashboard but not in the tracking tab. Also wont let me export the entries, it says access restricted.

Any advice would be greatly appreciated

Thanks

February 21, 2012
7:57 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

are you using some form of user mgmt plugins?

you also might want to check your Javascript Console for errors…

February 21, 2012
10:44 pm
profeddieb
Guest
I am getting the same error:
Took a look at javascript console:  Getting the following error 
POST /wp-content/plugins/cforms/js/include/lib_database_overview.php
   
500 Internal Server Error
I do not have any user management plugins running.  I will continue to try and de-bug, but thought I would add to the discussion now, to see if it helps.
Thanks!
Ed
February 22, 2012
7:46 am
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

Are you on the latest WP and cforms version?

Perhaps the server's PHP log may reveal more info on what is causing the 500 err…

February 22, 2012
5:19 pm
profeddieb
Guest

Yes I am on the latest version of both WP and cforms.  I will check the logs and see if I can find anything.  Thanks

February 22, 2012
5:32 pm
profeddieb
Guest

Figured it out.  It's a permission issue.  The cForms directory (and every underneath) needs to be 755.  For some reason my directory was changed to 777.

 

Everything is working fine, once I made this change, everything worked fine.  The log is what gave it away:

[Wed Feb 22 11:21:44 2012] [error] [client 99.118.238.31] SoftException in 
Application.cpp:256: File 
"/home/profeddi/public_html/juli/wp-content/plugins/cforms/js/include/lib_database_overview.php" 
is writeable by group, 
referer: http://www.juliwalter.com/wp-admin/admin.php?page=cforms/cforms-database.php
 
The referer was throwing the file does not exist error.
 
Thanks for your suggestion to look at the logs. Hope this helps the first poster.
 
profeddieb

February 26, 2012
12:52 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

thanks for the feedback, users rarely report back.

'very much appreciated!

May 23, 2012
11:53 am
katjam
Guest

changing to 755 from 777 fixed it for me too.

January 5, 2013
12:47 am
Meet
Guest

Hi I am using Wordpress 3.5 and latest current version of cforms and have similar problem as jo. I did what profeddieb did(i.e changing directory permission to 755) and didn't helped anything and I am getting "POST /wp-content/plugins/cforms/js/include/lib_database_overview.php load-scripts.php" error in google console and hangs on "Processing, please wait..)

Any help or solutions?

February 4, 2013
8:23 am
medsclub
Guest

I have exactly the same issue, with the same configuration except that my directories were all with permission 755 already.

February 5, 2013
4:06 am
Riyaz
Guest

Yes, I've just checked my directory permissions, all are 755 already.

The thing is, when I submit the form it does email the results, and in the database it stores to cformssubmissions, but in the cformsdata table it only store the value for the page field, thats strange because it was working perfectly until today, I have no idea what the problem is. Any help would be greatly appreciated. 

Thank you.  

February 14, 2013
6:06 am
Tim
Guest

It seems to be that the include files are throwing a 500 error. That 500 error seems to be set by the wp_die() function from the ## mini firewall code.

### mini firewall
if( !current_user_can('track_cforms') )
 wp_die("access restricted.");

 

When checking the permissions on the actual file, it seems my user id is set to 0, which WordPress considers not logged in.

I'm not sure why that's happening. I've tried messing with the file permissions with various types of rwx / ownership types with no luck. If any one has any insight, it would be very much appreciated.

February 18, 2013
12:49 am
ManFisher
Guest

Hi there. I have the same problem.

When I commented out the 

#if( !current_user_can('track_cforms') )
# wp_die("access restricted.");

lines in wp-content/plugins/cforms/js/include/lib_database_overview.php

it worked. But that is not a final solution!

Forum Timezone: Europe/Berlin

Most Users Ever Online: 959

Currently Online:
25 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

tracedef: 43

mores: 21

Gyrus: 20

frozenwaste: 18

asuffredini: 15

photoworks: 14

Member Stats:

Guest Posters: 3712

Members: 1463

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 5310

Posts: 18671

Newest Members: juredujmovic, dreamkeeper, rajattyagi, wrokaa, lukass

Moderators: Paul (421), cnymike (8), sonika (95)

Administrators: Oliver (6400), Nicky (3)