cforms II User Forum

Registration is currently disabled.
Guest

FAQs

Login form protected by Login LockDown.


Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

    

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
Cforms tracking broken... wordpress 2.2
July 21, 2007
10:00 pm
William
Guest

Running firefox 2.0.0.5

page iim getting error on : wp-admin/admin.php?page=contactforms/cforms-global-settings.php

 cforms version 5.3

 error im getting

 Warning: require_once(/var/www/vhosts/prewittandtodd.com/httpdocs//wp-admin/admin-functions.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/vhosts/prewittandtodd.com/httpdocs/wp-admin/upgrade-functions.php on line 5

Fatal error: require_once() [function.require]: Failed opening required '/var/www/vhosts/prewittandtodd.com/httpdocs//wp-admin/admin-functions.php' (include_path='.:.:') in /var/www/vhosts/prewittandtodd.com/httpdocs/wp-admin/upgrade-functions.php on line 5

im running wordpress 2.2

php 5.2.3

mysql 4.1.20

 i get that error when i try to activate tracking… and i need tracking badly because I can't get wordpress to send out the emails… and I can't seem to figure out why to save my life…

July 21, 2007
11:06 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

Email seems to work fine, I've received the CC.

Your Tracking tables have not been properly created, this is the error message your server produces (can be seen in Firefox/Firebug!):


[Table 'wordpress.wp1_cformsdata
' doesn't exist]

So either disable and re-enable DB Tracking. If this doesn't help, you need to find out why the Tracking tables can not be created in your WP database.

The error msg you posted has no reference to cforms, not sure where this is coming from. 

July 22, 2007
4:28 am
William
Guest

well i was just trying to figure out why it wouldn't create the tables itself because this wordpress install i put together on a wordpress 2.1 with cforms 4.8

 

i moved to a new server and decided I would upgrade everything and didn't know if the cforms tracking db structure had changed (because wordpress's has had to remake all my categories :( ) 

 

 but i ended up just tossing in the sql from my database back up from the old server and tracking works now

 

 

but Im still not getting any emails from my wordpress install :(  not from comments, password change requests anything :(

 

anything you know that could help me with that? 

July 22, 2007
9:46 am
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

Glad to hear it's working now.

The cforms email I received fine, so the general setup loos ok, since cforms also only uses the core PHP mail() function (so does WP).

You may want to double check all of your WP admin settings. 

July 22, 2007
9:25 pm
William
Guest

I just found out that it is only send the CC's :(

July 22, 2007
9:54 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

before it sends the CC or auto confirmation cforms checks for proper "send-results" to the admin – so the local mailer must have returned an "OK" for the admin email.

double check your admin email address, spelling, your spam folder etc. 

July 23, 2007
8:49 pm
William
Guest

hey everyone just letting everyone in on the conclusion to my problem with my emails.

I use google apps for my email and for some reason google
apps is dropping all of the emails from our server

I figured it out because other email services were getting the emails

now of course if this were just for me I would just use a non google
apps email but this is for a client and I've set up their emails on
google apps :(

So I've got to figure out how to get google apps to accept emails from
our server :( 

so everyone with email problems make sure you check more that one emails service

 

big thanks to oliver for creating a great plugin and being such a big help with figuring out problems with it :) 

July 25, 2007
10:31 am
William Harris
Guest

sorry oliver but im back this time with an all brand new shing new wordpress install along with a brand new cforms 5.3

 

apparently cforms isn't creating the tables for its sef….

 when I try to enable tracking the admin panel just goes blank and although tracking does show up beside plugin setting when you click it you get the error:

 

WordPress database error: [Table 'sylwordpress.wp_cformssubmissions' doesn't exist]
SELECT * FROM wp_cformssubmissions ORDER BY sub_date DESC

then if you click plugin setting again the tracking menu item disappears although the check box is still checked in the settings

I have the db table's structure from the back up of the other site so it won't slow me down but I was just letting you know

July 25, 2007
10:43 am
William Harris
Guest

do excuse the spelling in the previous post its rather late but to clear things up I have installed a fresh wordpress for another client with a brand new database and cforms and its appears cforms is not creating the database tables for its self 

July 25, 2007
10:38 pm
William Harris
Guest

 

apparently this is a wordpress svn problem because of the a function being in a dfferent place cforms wasn't able to use it here is the solution 

from oliver: 

the table creation process uses the "dbDelta($sql);" function which
for the stable WP releases resides in wp-admin/upgrade-functions.php
- this file doesn't seem to be present (from what I can see). Hence the
plugin causes an error (page also doesn't get reloaded completely) and
never creates those tables.

possible fix, replace (cforms-global-settings.php):

require_once(ABSPATH . 'wp-admin/upgrade-functions.php');

with

require_once(ABSPATH . 'wp-admin/includes/upgrade.php');

 

remember you should only have this problem if you are using SVN wordpress! 

 

 

Forum Timezone: Europe/Berlin

Most Users Ever Online: 959

Currently Online:
23 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

tracedef: 43

mores: 21

Gyrus: 20

frozenwaste: 18

asuffredini: 15

photoworks: 14

Member Stats:

Guest Posters: 3741

Members: 1463

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 5341

Posts: 18708

Newest Members: juredujmovic, dreamkeeper, rajattyagi, wrokaa, lukass

Moderators: Paul (421), cnymike (8), sonika (95)

Administrators: Oliver (6400), Nicky (3)