cforms II User Forum

Registration is currently disabled.
Guest

FAQs

Login form protected by Login LockDown.


Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

    

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS Related Topics
Cforms not working! (One moment please...)
February 24, 2013
11:39 pm
just a user
Guest

Hello,

Successful solution found.

I was getting the same error.  As it turned out, the cforms did not give the correct link for my wp installation that was installed in the subdirectory.

For example, my wp installation is at a subdirectory http://www.example.com/mywpinstall

The default link line in the cforms/js/cforms.js incorrectly omits the /mywpinstall/ part in the link

To fix this, instead of 

var sajax_uri = '/wp-content/plugins/cforms/lib_ajax.php';

USE (substitute your correct wp directory name in place of mywpinstall)

var sajax_uri = '/mywpinstall/wp-content/plugins/cforms/lib_ajax.php';

OR USE DYNAMIC SETTING as

var sajax_uri = window.location.protocol + "//" + window.location.host+'/mywpinstall/wp-content/plugins/cforms/lib_ajax.php';

Thanks to flippertie for pointing this out in an earlier post, but I too missed this post.  I hope this info gets added to the FAQ.

March 1, 2013
10:41 pm
RonnieG
Guest

My site (currently http://www.goodmangenealogy.org) is hosted on GoDadddy, and I knew from past experiences that they require smtp to submit all outgoing emails from WP websites hosted on their servers. So I configured cforms accordingly, using the same smtp settings and logins that I had successfully used elsewhere, including my Outlook email client. It didn't work.

For cforms settings, I checked, confirmed and tried absolutely everything posted in the FAQs and in this thread, all to no avail. Using Firefox with Firebug and its console debugging option, I saw that no matter what I did, I got "authentication failed" response.

I deactivated this plugin and tried another one, with similar issues. However, that plugin author provided a specific FAQ for Godaddy hosted sites, which mine is, and hat finally solved the problem for both plugins.

See: http://www.fastsecurecontactform.com/godaddy-email

First, I installed and configured the WP Mail SMTP plugin they recommended, configured it as specified in their FAQ, and tested it. It Worked!

Then I then deactivated the WP Mail SMTP plugin, reactivated cforms, and applied the same exact smtp and email settings to my cforms smtp setup, but it still did not work.

Then I reactivated the WP Mail SMTP plugin, changed the cforms global email settings to use the standard WP php mail function instead of smtpout, with no other changes to anything in cforms, submitted a cforms test contact form, and voila, that worked!

So, problem solved for me, as long as I use the WP Mail SMTP plugin. But there is apparently still some kind of smtp bug in cforms when attempting to authenticate with the Godaddy smtp server. With this solution, and perhaps a review of the working smtp authentication code in the WP Mail SMTP plugin, maybe it can be fixed. Or, maybe cforms should simply specify the use of the same the WP Mail SMTP plugin, strip out its own internal smtp code, and let someone else (another plugin author) be responsible for all smtp server compatibility issues.

July 24, 2013
1:53 pm
vignes
Guest

HI.

comment has already been posted…?

September 30, 2013
8:12 am
Aram
Guest

I am having the same problem, My form worked for nearly 4 years…but now I have a problem….I have tried to change the ajax path, tried all possible versions related to the path, but it is still not working…how to solve the issue…?

Thank You!

October 3, 2013
12:57 am
Chaz1138
Guest

There may be an even simpler solution:  uncheck the Ajax enabled box on the first section of the form settings.

I just did this for an install of cforms running on GoDaddy and that seems to have solved the problems. 

January 18, 2014
3:57 am
Bec
Guest

What's weird about the "one moment please" message not showing up for my form is that:

1) this only happens in Safari 7 (oddly enough, the "one moment please" message showed up when I tested it with Safari 5)

2) I open web inspector and stare at the source code while I click submit, and in the code I can see the span with "one moment please" inside it showing up right away. It just doesn't show up on the page.

3) everything else works. All the other error/success messages work except for this one.

4) when I click on stop and stop the page from loading, then the "one moment please" message shows up!

5) don't know if this means anything, but the background gif I put into the css for the "one moment please" message doesn't show up in Safari (both 5 and 7). But it works in Chrome and Firefox.

6) I don't think it has anything to do with the css since I tried it without css just to check. Doesn't solve the problem.

I tried changing cforms.js, emptying cache, restart, etc… it didn't change anything. I guess it's not a huge problem because everything else works. I'm just driving myself crazy trying to figure out what could be causing this weirdness. I think I blame Safari. sf-wink But how to get around it seems to be beyond my powers. sf-yell

Forum Timezone: Europe/Berlin

Most Users Ever Online: 959

Currently Online:
28 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

tracedef: 43

mores: 21

Gyrus: 20

frozenwaste: 18

asuffredini: 15

photoworks: 14

Member Stats:

Guest Posters: 3740

Members: 1463

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 5340

Posts: 18707

Newest Members: juredujmovic, dreamkeeper, rajattyagi, wrokaa, lukass

Moderators: Paul (421), cnymike (8), sonika (95)

Administrators: Oliver (6400), Nicky (3)