cforms II User Forum

Registration is currently disabled.
Guest

FAQs

Login form protected by Login LockDown.


Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

    

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
cforms hangs after submit, One moment please ...
January 13, 2011
9:40 pm
zenofwordpress
Guest

Paul,

 

Thanks for your reply.  I don't follow you, though.

 

Here is what the note says on the page to set up alternate form: "If you enable an alternative form action you will loose any cforms application logic (spam security, field validation, DB tracking etc.) in non-ajax mode!".  While it does not explicitly say it, to me this says the cforms application logic does work with ajax turned on.

 

In any event, I will try your 2 part form idea, as I need to get this to work. 

January 13, 2011
10:16 pm
zenofwordpress
Guest

Paul,

 

I just tried you suggestion about the multi part form.  Validation, captcha, and browser going to alternate form all work OK.  However, this solution does not pass the input form data to the alternate form which is what I need and is the whole point of me doing the alternate for in the first place.

January 13, 2011
10:45 pm
Paul
Amsterdam, NL
Moderator
Forum Posts: 421
Member Since:
February 10, 2009
Offline

I think the description said 'you will loose any…' as to not raise any hopes that it would work, again this was meant for developers and not per se a fully functional feature, as I understand it – perhaps Oliver can chime in.

Anyway, per his last post, the next release will support what you've tried to do initially.

 

My work around merely added an in-between step, so your last/second form in fact has to have

  • the same input fields as the 1st (they can be hidden via CSS!)
  • and point to the alternative action for rerouting the form data

 

…or simply wait for v11.7.2.

 

Paul.

* Paul Silter
January 13, 2011
11:06 pm
Guest

Paul,

 

Thanks for your clarification regarding the multi-part form.  I will give it a shot.   I noticed that turning on the multi-part caused CForms to turn off ajax.  Given that in my multi-part form validation and captcha are still working, then given your comment, "Oliver just posted that v11.7.2 is going to support such Javascript validation for all browsers. ;-)", what is causing the validation to work now?

 

Greg

 

P.S. yes, it would be great if Oliver could comment on all parts of this thread.

January 14, 2011
7:29 am
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

You both were right.

Firefox indeed supported JS based form validation for alternative form actions even though it wasn't meant to be included for starters.

Due to high request I modified the JS part to accommodate cross browser JS field validation *before* the form & field data is sent off to the remote address.

Stay tuned, v11.7.2 is about to be released shortly.


PS: I think Paul forgot to mention that for the workaround to work, both forms not only need to have the same form fields, but also need to have all form fields use the same custom form field IDs (feature must be turned on, too)! The key is, that the form data is sent from form #1 to #2 and that only happens when the field names/ids are identical.

October 14, 2011
10:20 pm
Dave
Guest

I had the same problem.  Go to ccformsII Forms Settings and beside your form name, uncheck Ajax enabled.  The form should then process immediately.

October 17, 2013
9:53 am
vivek
Guest

Following need to update at /js/cforms.js

var sajax_uri = '/wp-content/plugins/cforms/lib_ajax.php';

to your relative url to the domain:

For example i use

var sajax_uri = '/blog/wp-content/plugins/cforms/lib_ajax.php';

Hopefully this is a fix for all.

December 9, 2013
8:33 am
Ben
Guest

Hello there, 

Congrats on a great and unique plugin! been looking for a while for something like this. Thank you guys, i'll be happy to donate but first need to accomplish my goals and here's what's stopping me.

Problem is that I can't get the uploaded images links on the Tracking system to work, no matter what I get a 404 error.  Looking around and after changing the ABSPATH to 

<?php $abspath = '/home2/homeboox/public_html/myblog/'; ?>

and the CFORMS.JS to

var sajax_uri = window.location.protocol + "//" + window.location.host+'/myblog/wp-content/plugins/cforms/lib_ajax.php';

i realized by inspecting the IMAGE LINK when viewing records, that as you can see…

<a href="http://homeboox.com/myblog/wp-content/plugins/cforms/homeboox/public_html/myblog/wp-content/PublishFormUploads/image.jpg">image.jpg</a>

for some reason is taking 2 addresses and concatenating them together.

Can you please help me fix this problem.  I really don't know much but it seems that it's taking the first half from the Upload directory (absolute path) /home2/homeboox/public_html/myblog/wp-content/PublishFormUploads field (which can't get to change and save anymore(?)) and the second half looks like it's coming from the cforms.js file.  Not sure.

Thank you for your time and knowledge, and sorry if my english is not good

June 26, 2014
10:54 pm
Kevin
Guest

http://rmdmotors.com/2004-kenny-roberts-proton-krv…..s-roberts/

WP 3.9.1

cforms 11.5

captcha 4.0.1

Browser Chrome 35

The form does get submitted but it hangs on the "One moment please… " message.

Thank you.

Forum Timezone: Europe/Berlin

Most Users Ever Online: 959

Currently Online:
36 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

tracedef: 43

mores: 21

Gyrus: 20

frozenwaste: 18

asuffredini: 15

photoworks: 14

Member Stats:

Guest Posters: 3732

Members: 1463

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 5333

Posts: 18693

Newest Members: juredujmovic, dreamkeeper, rajattyagi, wrokaa, lukass

Moderators: Paul (421), cnymike (8), sonika (95)

Administrators: Oliver (6400), Nicky (3)