cforms II User Forum

Registration is currently disabled.
Guest

FAQs

Login form protected by Login LockDown.


Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

    

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
cform does not apear in admin-menu any more
December 5, 2007
11:19 pm
gero
Guest

Please replace the ??? with your data!

  • Your URL: http://???
  • The browser used: Firefox 2.0
  • cforms version: 6.4
  • Your Wordpress version: 2.3.1

After some deactivating, activating and updating cforms I now have the strange problem, that there is no "cform II" menu item any more, although cform does appear in the plugin list and it can be activated and deactivated, but there is no link in the blue admin menu-ribbon. any ideas?

December 6, 2007
7:10 am
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

I have no idea, maybe something buggy with your WP install?

Are you using User Roles Management?

Can you deactivate, remove the entire cforms folder and upload it again, picking a new folder name, e.g. /contactforms6.4 …?

December 9, 2007
1:01 am
cm
Guest

I have a similar problem.  CForms is not appearing in my admin bar.  The button appears on my posts and pages editors and I can add the default form, but I have no way to get into the CForms editor itself.  I've tried pasting in the url to CForms admin (copied from another site where CForms is working properly) but I can get an error message that says access is denied.  Suggestions?

December 9, 2007
8:28 am
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

Possibly an .htaccess file, other plugins, file permissions, corrupt files…I'll send you an email.

December 9, 2007
1:58 pm
gero
Guest

Just deactivated version 6.4, deleted the folder and uploaded 6.41 in folder /contactforms6

No success :( after activating still no cform II entry in the menu bar.

i used to have custom admin menu installed, but deactivaded and deletet it. i even deactivated all plugins and only activated cforms, but it's not in the menu.

any ideas?

December 9, 2007
5:57 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

Resolved.

There was a problem with web server variable 'SCRIPT_FILENAME', which wrongly points to: /usr/local/apache/share/cgi-bin/php4

Instead it should point to /your/path/to/wordpress/wp-admin/admin.php

Quick fix: simply replace this block in cforms.php (bottom):

### dashboard
if ( $_SERVER['SCRIPT_FILENAME'] <> '' )
$loc = $_SERVER['SCRIPT_FILENAME'];
else if ( $_SERVER['SCRIPT_URI'] <> '' )
$loc = $_SERVER['SCRIPT_URI'];
else
$loc = "/wp-admin/index.php";

 

with just:

$loc = "/wp-admin/index.php";

 

December 9, 2007
8:08 pm
gero
Guest

Thank you for your help!

Now it's really time to donate something for that great plugin with the great support Money mouthSmile

 

December 10, 2007
3:43 pm
cm
Guest

beautimous.  thnx.

Forum Timezone: Europe/Berlin

Most Users Ever Online: 959

Currently Online:
26 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

tracedef: 43

mores: 21

Gyrus: 20

frozenwaste: 18

asuffredini: 15

photoworks: 14

Member Stats:

Guest Posters: 3757

Members: 1463

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 5356

Posts: 18735

Newest Members: juredujmovic, dreamkeeper, rajattyagi, wrokaa, lukass

Moderators: Paul (421), cnymike (8), sonika (95)

Administrators: Oliver (6400), Nicky (3)