cforms II User Forum

Registration is currently disabled.
Guest

FAQs

Login form protected by Login LockDown.


Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

    

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
Required field text doesn't show up next to select boxes
October 16, 2007
12:30 am
Dalton
Guest

First off, this is a great plugin, mate! Where's the donate button? Laughing

I have some slightly more advanced questions to ask, but those will have to wait until I'm a bit more clear-headed. For now, I just have a question about what I think might be a bug. When making a select box a required field, the text "required field" doesn't show up. Any idea where it might have gone?

Please see below and note that "State" is supposed to be a required field on this form. I'm using version 5.5 with WP 2.3, the page can be found here:

http://beta.storycorps.net/about/inquiries/mobile-booth

October 16, 2007
7:52 am
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

There is no donate button, but you're welcome to advertise in the tech forum :-)

You're right about the select box, this topic came up beforeI think I should really turn it back on by a default…

 

October 16, 2007
10:40 pm
Dalton
Guest

Thanks, that worked. Yeah, I think it might make sense to keep it on, it can be confusing otherwise.

December 17, 2007
10:26 pm
Susan
Guest

Hi,

Sorry for bringing up an old post, but I have a question about this. I was able to get the required text (on my site, it's just an *) to show up, but the field still isn't actually required. I can still submit the form without actually making a selection in the box.

Could you give me a pointer? http://thewebdesignloft.com/contact

ETA:  Also, when I receive the email, the info from the select box doesn't appear in the email.

Thanks!
Susan

December 17, 2007
11:31 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

I take it that you have set the field to be "required", now all you need to do, is add a '-' (minus) as the default value for the first field 'Please choose', ie.

MyOptions#Please choose|-#option1#option2#… 

(make sure there are no unecessary spaces after the '|') 

December 18, 2007
12:38 am
Susan
Guest

Thank you so much!  This works perfectly!

February 20, 2008
5:32 pm
Sdevil
Guest

Hi

I have a similar problem. Have a look at my site http://www.propertysaleforcash.com  The required filed text shows up fine in IE but does not show up in Firefox… Can you please see if i am diong something wrong?

 

Thanks

Sdevil

February 20, 2008
9:39 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

Using FF, it looks fine too me, what is not working on your end?

Forum Timezone: Europe/Berlin

Most Users Ever Online: 959

Currently Online:
27 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

tracedef: 43

mores: 21

Gyrus: 20

frozenwaste: 18

asuffredini: 15

photoworks: 14

Member Stats:

Guest Posters: 3762

Members: 1463

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 5361

Posts: 18742

Newest Members: juredujmovic, dreamkeeper, rajattyagi, wrokaa, lukass

Moderators: Paul (421), cnymike (8), sonika (95)

Administrators: Oliver (6400), Nicky (3)