cforms II User Forum

Registration is currently disabled.
Guest

FAQs

Login form protected by Login LockDown.


Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

    

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
cforms V3 look bad in IE7
April 4, 2007
10:40 pm
Tomsn
Guest

Hi there,

first: i like your contactform Cool but: in IE7 and IE6 the form is always on the top of the page and the send buttn is on the bottom of the page… on Firefox it looks well

any idea?

 Tomsn

April 4, 2007
10:52 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

Tomsn said:

Hi there,

first: i like your contactform Cool but: in IE7 and IE6 the form is always on the top of the page and the send buttn is on the bottom of the page… on Firefox it looks well

any idea?

 Tomsn


Can you please provide a URL? With the thousands of WP themes out there it's always difficult to say why a specific layout looks the way it does. I assume you've searched the comments/FAQs for typical layout issues…

April 5, 2007
8:21 pm
Tomsn
Guest

Hi Oliver
sorry, forgott this :-)
http://clubwir.at

April 5, 2007
11:10 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

Tomsn,
Looking at your WP layout I noticed that you're columns and (div) containers use a lot of position:relative styles. This may cause the form element to not display 100% correctly. A few things you could try…

  1. add a display:block; to #loop_page
  2. add a overflow:visible; to .cforms
  3. set a specific margin-left for.cforms (instead of auto)

It's difficult to remotely analyze IE layout issues (FF is simpler) but perhaps one of these will help.

April 9, 2007
10:58 am
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

I think I found the actual source of the problem! Find the below line in your cforms.css file:

.cformfieldsets { margin:10px 0; padding:8px 0 11px 0; border:1px solid #adadad; border-left-color:#ececec; border-top-color:#ececec; clear:left; }

And remove the last attribute clear:left this fix has been reported to solve the majority of IE display issues concerning 3 column WP themes with a non-floated center piece.

Hope this works for your theme as well.

April 9, 2007
7:50 pm
Tomsn
Guest

Hi Oliver

sorry, does have no effect on IE7 and IE6 … :(

have a look here: http://www.clubwir.at/?page_id=2

maby this helps you more, i'm using the subtle theme: http://blog.gluedideas.com/downloads/subtle/

 

Tomsn 

April 12, 2007
9:25 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

quick heads-up: issue resolved by correcting the sendbutton style. See FAQ.

April 12, 2007
10:10 pm
Tomsn
Guest

Hi Oliver

thanks for your last help via Email, the Form looks now nearly perfect in IE6 and IE7

:-) 

Tomsn 

July 6, 2007
12:47 pm
Suphi
Guest

Dear Oliver,

What was the solution that you come up with for IE styling. I had to change the default style to make the sendbutton larger, then everything f*** up in IE. (FF is fine as always) and I'm lost in your website, cannot find the FAQ. I'll keep searching. But please help me.

 .cform input.sendbutton {
 width: 150px; 
 padding: 2px;
 margin: 10px 0 0 310px;
 font-size:0.8em;
 background:url(../images/button-bg.gif) repeat-x;
 border:1px solid #adadad!important;
 border-left-color:#ececec!important;
 border-top-color:#ececec!important;
}

Best,

Suphi

July 6, 2007
8:12 pm
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

…then everything f*** up in IE.

Doesn't really help to understand the issue, can you post a URL showing the broken layout?

Here is the FAQ post.

August 7, 2007
7:01 am
Tans
Guest

I also, am having IE issues when everything looks as it should in firefox *mumbles at IE*

Any pages that have a form displayed, the center column in my 3-column theme falls to the end of right column.

I've been here previously, but not about the same problem and found the answer by reading around and finding someone else having the same problem. I've done the same thing again and can remember someone having the same problem as I am currently but I hadn't read up on it, and now that I'm trying to find it, and I can't. LOL

Here are pages where the form exists:

http://tanyaiscrazy.com/main/?page_id=123

http://tanyaiscrazy.com/main/?page_id=32

http://tanyaiscrazy.com/main/?page_id=23

If you need anything else, let me know.

I've tried upgrading to cform ver 5.3 and it didn't fix, I also tried moving the send button more to the left and that didn't help either.

Thanks for your help! 

August 7, 2007
7:23 am
Oliver
Munich, Germany
Admin
Forum Posts: 6400
Member Since:
March 6, 2005
Offline

Your #content div container is set to 350px. cforms is configured to 410px, that's the issue.

I recommend you tweak cforms CSS until is fits into 350px, adjusting the overall width to 330px; look for .cform { …

This might already be it… 

August 7, 2007
7:40 am
Tans
Guest

Oooooooh! Don't you just rock!! LOL Thanks for the quick reply, Oliver! Much appreciated, you are so helpful! I can't believe I didn't see that, but I appreciating you pointing the problem out! I had the problem existing on 2 themes, 2 different blog installations and now they are both fixed! Thankies!

Forum Timezone: Europe/Berlin

Most Users Ever Online: 959

Currently Online:
17 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

tracedef: 43

mores: 21

Gyrus: 20

frozenwaste: 18

asuffredini: 15

photoworks: 14

Member Stats:

Guest Posters: 3740

Members: 1463

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 5340

Posts: 18707

Newest Members: juredujmovic, dreamkeeper, rajattyagi, wrokaa, lukass

Moderators: Paul (421), cnymike (8), sonika (95)

Administrators: Oliver (6400), Nicky (3)